Print Friendly and PDF

Zeta ZL6104 'Non-volatile memory error was detected' but TSSF command shows no memory errors

Hi,

I'm hoping someone can clarify the an error I have with a Zeta ZL6104 drive. I've searched the Parker.com forum to no avail.

When I power up the drive the Motion Architect Terminal reports '*****Non-volatile memory error was detected*****'.

However, when I run the TSSF command the Memory Error line displays 'No'.

*TSSF
*System Ready                  YES     Thumbwhl Data Load NO  
*Reserved                           NO        Ext Prog Sel Mode      NO  
*Program Executing         NO      Time Command            NO  
*Immediate Comm Last  NO      Waiting RP240 Data    NO  
*
*Ascii Mode                  YES     RP240 Connected   NO  
*Echo Mode                 YES     Memory Error            NO  
*Defining a Program  NO      Servo Data Transfer NO  
*Trace Mode                 NO      Reserved                   NO  
*
*Step Mode                  NO      Pos captured TRG-A   NO  
*FS Translate Mode   NO      Pos captured TRG-B   NO  
*Command Error       NO      Pos captured TRG-C  NO  
*Break Point Active   NO      Pos captured TRG-D  NO  
*
*Pause Active                NO      Comp Mem Near Full  NO  
*Wait Active                   NO      Compiled Mem Full     NO  
*Checking On Conds  NO      Compile Error              NO  
*Waiting for Data    NO      Reserved            NO

Am I right in thinking that the 'working' RAM IC is faulty and not the 'battery-backed' Non-Volatile RAM IC?

I have not tried a battery disconnect hardware reset yet.

Thanks!